using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:Ahmet|[Aa](?:hmetlii))\b";
string input = @"Ahmetlii OK
ahmetlii OK
Ahmet OK, not preferred but no problem
ahmet Definitely not (use uppercase in first letter) ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}