re = /\b(?:Ahmet|[Aa](?:hmetlii))\b/m
str = 'Ahmetlii OK
ahmetlii OK
Ahmet OK, not preferred but no problem
ahmet Definitely not (use uppercase in first letter) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end