$re = '/\b(?:Ahmet|[Aa](?:hmetlii))\b/m';
$str = 'Ahmetlii OK
ahmetlii OK
Ahmet OK, not preferred but no problem
ahmet Definitely not (use uppercase in first letter) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);