using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{8,}";
string input = @" 111 1111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}