re = /\d{8,}/
str = ' 111 1111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end