package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{8,}`)
var str = ` 111 1111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}