$re = '/\d{8,}/';
$str = ' 111 1111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1
111 1111111111111111 11 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);