using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MTN_AFGHANISTAN_RGS30_.*.csv$";
string input = @"MTN_AFGHANISTAN_RGS30_20200912_20201011.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}