re = /MTN_AFGHANISTAN_RGS30_.*.csv$/m
str = 'MTN_AFGHANISTAN_RGS30_20200912_20201011.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end