$re = '/MTN_AFGHANISTAN_RGS30_.*.csv$/m';
$str = 'MTN_AFGHANISTAN_RGS30_20200912_20201011.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);