package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)MTN_AFGHANISTAN_RGS30_.*.csv$`)
var str = `MTN_AFGHANISTAN_RGS30_20200912_20201011.csv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}