#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)providers:\s*-\s*\baescbc:"
Local $sString = "kind: EncryptionConfig" & @CRLF & _
"apiVersion: v1" & @CRLF & _
"resources:" & @CRLF & _
" - resources:" & @CRLF & _
" - secrets" & @CRLF & _
" providers:" & @CRLF & _
" - aescbc:" & @CRLF & _
" keys:" & @CRLF & _
" - name: key1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")