using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"providers:\s*-\s*\baescbc:";
string input = @"kind: EncryptionConfig
apiVersion: v1
resources:
- resources:
- secrets
providers:
- aescbc:
keys:
- name: key1";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}