re = /providers:\s*-\s*\baescbc:/
str = 'kind: EncryptionConfig
apiVersion: v1
resources:
- resources:
- secrets
providers:
- aescbc:
keys:
- name: key1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end