package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)providers:\s*-\s*\baescbc:`)
var str = `kind: EncryptionConfig
apiVersion: v1
resources:
- resources:
- secrets
providers:
- aescbc:
keys:
- name: key1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}