#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((02\/[0-2]\d)|((01|[0][3-9]|[1][0-2])\/(31|30|[0-2]\d)))\/[12]\d{3}"
Local $sString = "01/02/2017 #pass" & @CRLF & _
"12/31/2017 #pass" & @CRLF & _
"02/31/2017" & @CRLF & _
"02/12/2017" & @CRLF & _
"1/02/2017 #fail" & @CRLF & _
"01/2/2017 #fail" & @CRLF & _
"50/01/2017 #fail" & @CRLF & _
"01/50/2017 #fail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")