const regex = /((02\/[0-2]\d)|((01|[0][3-9]|[1][0-2])\/(31|30|[0-2]\d)))\/[12]\d{3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((02\\\/[0-2]\\d)|((01|[0][3-9]|[1][0-2])\\\/(31|30|[0-2]\\d)))\\\/[12]\\d{3}', 'g')
const str = `01/02/2017 #pass
12/31/2017 #pass
02/31/2017
02/12/2017
1/02/2017 #fail
01/2/2017 #fail
50/01/2017 #fail
01/50/2017 #fail`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}