$re = '/((02\/[0-2]\d)|((01|[0][3-9]|[1][0-2])\/(31|30|[0-2]\d)))\/[12]\d{3}/';
$str = '01/02/2017 #pass
12/31/2017 #pass
02/31/2017
02/12/2017
1/02/2017 #fail
01/2/2017 #fail
50/01/2017 #fail
01/50/2017 #fail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);