#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(.*?)(-+\n.*?-+(?:\n|\Z))(.*?)(?=-+|\Z)"
Local $sString = "some text" & @CRLF & _
"----" & @CRLF & _
"text inside special block" & @CRLF & _
"----" & @CRLF & _
"some text" & @CRLF & _
"----" & @CRLF & _
"----" & @CRLF & _
"some text" & @CRLF & _
"----" & @CRLF & _
"text inside special block" & @CRLF & _
"----" & @CRLF & _
"some text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")