import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(-+\\n.*?-+(?:\\n|\\Z))(.*?)(?=-+|\\Z)";
final String string = "some text\n"
+ "----\n"
+ "text inside special block\n"
+ "----\n"
+ "some text\n"
+ "----\n"
+ "----\n"
+ "some text\n"
+ "----\n"
+ "text inside special block\n"
+ "----\n"
+ "some text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}