re = /(.*?)(-+\n.*?-+(?:\n|\Z))(.*?)(?=-+|\Z)/m
str = 'some text
----
text inside special block
----
some text
----
----
some text
----
text inside special block
----
some text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end