import re
regex = re.compile(r"(.*?)(-+\n.*?-+(?:\n|\Z))(.*?)(?=-+|\Z)", flags=re.MULTILINE | re.DOTALL)
test_str = ("some text\n"
"----\n"
"text inside special block\n"
"----\n"
"some text\n"
"----\n"
"----\n"
"some text\n"
"----\n"
"text inside special block\n"
"----\n"
"some text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")