const regex = /(?<=[\.?!]\s|^)([a-z])|(\bi(?=\b|'))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\.?!]\\s|^)([a-z])|(\\bi(?=\\b|\'))', 'gm')
const str = `the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand.
why am i short? it's not lke i'm not eating or anything, i'm just short!`;
const subst = `\U$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);