import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^hsla?\\((?:(-?\\d+(?:deg|g?rad|turn)?),\\s*((?:\\d{1,2}|100)%),\\s*((?:\\d{1,2}|100)%)(?:,\\s*((?:\\d{1,2}|100)%|0(?:\\.\\d+)?|1))?|(-?\\d+(?:deg|g?rad|turn)?)\\s+((?:\\d{1,2}|100)%)\\s+((?:\\d{1,2}|100)%)(?:\\s+((?:\\d{1,2}|100)%|0(?:\\.\\d+)?|1))?)\\)$";
final String string = "hsl(123deg, 100%, 0%)\n"
+ "hsl(123, 100%, 0%)\n"
+ "hsl(123rad 100% 0%)\n"
+ "hsla(123grad, 100%, 0%, 0)\n"
+ "hsla(-123turn 100% 0% 1)\n"
+ "hsla(1 100% 0% 50%)\n\n"
+ "bad ones\n"
+ " hsl(123deg, 100%, 0%)\n"
+ "hsl(123, 100%, 0%) \n"
+ "hsl(123ad 100% 0%)\n"
+ "hsla(123grd, 100%, 0%, 0)\n"
+ "hsla(-123trn 100% 0% 1)\n"
+ "hsla(1 a% 0% 50%)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}