import re
regex = re.compile(r"^hsla?\((?:(-?\d+(?:deg|g?rad|turn)?),\s*((?:\d{1,2}|100)%),\s*((?:\d{1,2}|100)%)(?:,\s*((?:\d{1,2}|100)%|0(?:\.\d+)?|1))?|(-?\d+(?:deg|g?rad|turn)?)\s+((?:\d{1,2}|100)%)\s+((?:\d{1,2}|100)%)(?:\s+((?:\d{1,2}|100)%|0(?:\.\d+)?|1))?)\)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("hsl(123deg, 100%, 0%)\n"
"hsl(123, 100%, 0%)\n"
"hsl(123rad 100% 0%)\n"
"hsla(123grad, 100%, 0%, 0)\n"
"hsla(-123turn 100% 0% 1)\n"
"hsla(1 100% 0% 50%)\n\n"
"bad ones\n"
" hsl(123deg, 100%, 0%)\n"
"hsl(123, 100%, 0%) \n"
"hsl(123ad 100% 0%)\n"
"hsla(123grd, 100%, 0%, 0)\n"
"hsla(-123trn 100% 0% 1)\n"
"hsla(1 a% 0% 50%)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")