import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(/\\* \\d+ \\*/)/\\*.+";
final String string = "/* 7 */\n"
+ "margin-top:1.5rem!important/* 114 */\n"
+ "}/* 115 *//* 118 *//* 121 */\n"
+ ".mb-2{/* 122 */\n"
+ "margin-bottom:.5rem!important/* 123 */\n"
+ "}/* 124 *//* 127 *//* 130 *//* 133 *//* 137 */";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}