import re
regex = re.compile(r"(/\* \d+ \*/)/\*.+", flags=re.MULTILINE)
test_str = ("/* 7 */\n"
"margin-top:1.5rem!important/* 114 */\n"
"}/* 115 *//* 118 *//* 121 */\n"
".mb-2{/* 122 */\n"
"margin-bottom:.5rem!important/* 123 */\n"
"}/* 124 *//* 127 *//* 130 *//* 133 *//* 137 */")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)