use strict;
my $str = 'Some1String2That3Can4Include5Digits_123456.ext
SomeStringThatCanNOTIncludeDigits123456.ext
SomeString_12.ext
SomeString12.ext';
my $regex = qr~^(\w{3}).*?(\d{3,})?\.\w+$~mp;
my $subst = '\\1\\2';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";