import Foundation
let pattern = #"^(\w{3}).*?(\d{3,})?\.\w+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Some1String2That3Can4Include5Digits_123456.ext
SomeStringThatCanNOTIncludeDigits123456.ext
SomeString_12.ext
SomeString12.ext
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)