$re = '~^(\w{3}).*?(\d{3,})?\.\w+$~m';
$str = 'Some1String2That3Can4Include5Digits_123456.ext
SomeStringThatCanNOTIncludeDigits123456.ext
SomeString_12.ext
SomeString12.ext';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;