import re
regex = re.compile(r"^(\w{3}).*?(\d{3,})?\.\w+$", flags=re.MULTILINE)
test_str = ("Some1String2That3Can4Include5Digits_123456.ext\n"
"SomeStringThatCanNOTIncludeDigits123456.ext\n"
"SomeString_12.ext\n"
"SomeString12.ext")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)