#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a(?:\s+name=".*?")?\s+href=.*?#.*?>(.*?)<\/a>"
Local $sString = "<a href="http://example.com/books/1">The Lord of the Rings</a>" & @CRLF & _
"<ul>" & @CRLF & _
" <li><a href="http://example.com/books/1#c1" >Chapter 1</a></li>" & @CRLF & _
" <li><a name="name before href" href="http://example.com/books/1#c2">Chapter 2</a></li>" & @CRLF & _
" <li><a href="http://example.com/books/1#c3" name="name after href">Chapter 3</a></li>" & @CRLF & _
" <li><a href="http://example.com/books/1#cN" target="_blank">Chapter N</a></li>" & @CRLF & _
"</ul>" & @CRLF & _
"<br><br>" & @CRLF & _
"<a href="http://example.com/books/1">Harry Potter</a>" & @CRLF & _
"<ul>" & @CRLF & _
" <li><a href="http://example.com/books/2#c1" target="_self">Chapter 1</a></li>" & @CRLF & _
" <li><a href="http://example.com/books/2#c2" name="some have name" title="some others have title" >Chapter 2</a></li>" & @CRLF & _
" <li><a href="http://example.com/books/2#c3">Chapter 3</a></li>" & @CRLF & _
" <li><a href="http://example.com/books/2#cN" >Chapter N</a></li>" & @CRLF & _
"</ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")