using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a(?:\s+name="".*?"")?\s+href=.*?#.*?>(.*?)<\/a>";
string input = @"<a href=""http://example.com/books/1"">The Lord of the Rings</a>
<ul>
<li><a href=""http://example.com/books/1#c1"" >Chapter 1</a></li>
<li><a name=""name before href"" href=""http://example.com/books/1#c2"">Chapter 2</a></li>
<li><a href=""http://example.com/books/1#c3"" name=""name after href"">Chapter 3</a></li>
<li><a href=""http://example.com/books/1#cN"" target=""_blank"">Chapter N</a></li>
</ul>
<br><br>
<a href=""http://example.com/books/1"">Harry Potter</a>
<ul>
<li><a href=""http://example.com/books/2#c1"" target=""_self"">Chapter 1</a></li>
<li><a href=""http://example.com/books/2#c2"" name=""some have name"" title=""some others have title"" >Chapter 2</a></li>
<li><a href=""http://example.com/books/2#c3"">Chapter 3</a></li>
<li><a href=""http://example.com/books/2#cN"" >Chapter N</a></li>
</ul>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}