import re
regex = re.compile(r"<a(?:\s+name=\".*?\")?\s+href=.*?#.*?>(.*?)<\/a>")
test_str = ("<a href=\"http://example.com/books/1\">The Lord of the Rings</a>\n"
"<ul>\n"
" <li><a href=\"http://example.com/books/1#c1\" >Chapter 1</a></li>\n"
" <li><a name=\"name before href\" href=\"http://example.com/books/1#c2\">Chapter 2</a></li>\n"
" <li><a href=\"http://example.com/books/1#c3\" name=\"name after href\">Chapter 3</a></li>\n"
" <li><a href=\"http://example.com/books/1#cN\" target=\"_blank\">Chapter N</a></li>\n"
"</ul>\n"
"<br><br>\n"
"<a href=\"http://example.com/books/1\">Harry Potter</a>\n"
"<ul>\n"
" <li><a href=\"http://example.com/books/2#c1\" target=\"_self\">Chapter 1</a></li>\n"
" <li><a href=\"http://example.com/books/2#c2\" name=\"some have name\" title=\"some others have title\" >Chapter 2</a></li>\n"
" <li><a href=\"http://example.com/books/2#c3\">Chapter 3</a></li>\n"
" <li><a href=\"http://example.com/books/2#cN\" >Chapter N</a></li>\n"
"</ul>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")