import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a(?:\\s+name=\".*?\")?\\s+href=.*?#.*?>(.*?)<\\/a>";
final String string = "<a href=\"http://example.com/books/1\">The Lord of the Rings</a>\n"
+ "<ul>\n"
+ " <li><a href=\"http://example.com/books/1#c1\" >Chapter 1</a></li>\n"
+ " <li><a name=\"name before href\" href=\"http://example.com/books/1#c2\">Chapter 2</a></li>\n"
+ " <li><a href=\"http://example.com/books/1#c3\" name=\"name after href\">Chapter 3</a></li>\n"
+ " <li><a href=\"http://example.com/books/1#cN\" target=\"_blank\">Chapter N</a></li>\n"
+ "</ul>\n"
+ "<br><br>\n"
+ "<a href=\"http://example.com/books/1\">Harry Potter</a>\n"
+ "<ul>\n"
+ " <li><a href=\"http://example.com/books/2#c1\" target=\"_self\">Chapter 1</a></li>\n"
+ " <li><a href=\"http://example.com/books/2#c2\" name=\"some have name\" title=\"some others have title\" >Chapter 2</a></li>\n"
+ " <li><a href=\"http://example.com/books/2#c3\">Chapter 3</a></li>\n"
+ " <li><a href=\"http://example.com/books/2#cN\" >Chapter N</a></li>\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}