import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/songs/\\d+(?!.*/foo\\b)";
final String string = "/songs/902\n"
+ "/songs/902/\n"
+ "/songs/902/foo\n"
+ "/songs/902/foo/201/bar\n"
+ "/songs/902/bar";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}