const regex = new RegExp('/songs/\\d+(?!.*/foo\\b)', 'g')
const str = `/songs/902
/songs/902/
/songs/902/foo
/songs/902/foo/201/bar
/songs/902/bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}