$re = '~/songs/\d+(?!.*/foo\b)~';
$str = '/songs/902
/songs/902/
/songs/902/foo
/songs/902/foo/201/bar
/songs/902/bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);