re = /\/songs\/\d+(?!.*\/foo\b)/
str = '/songs/902
/songs/902/
/songs/902/foo
/songs/902/foo/201/bar
/songs/902/bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end