#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![#.])\S*\s*\{"
Local $sString = "#outlook a{" & @CRLF & _
" padding:0;" & @CRLF & _
"}" & @CRLF & _
"img[src="https://example.com"]{" & @CRLF & _
" -ms-interpolation-mode:bicubic;" & @CRLF & _
"}" & @CRLF & _
"table{" & @CRLF & _
" mso-table-lspace:0pt;" & @CRLF & _
" mso-table-rspace:0pt;" & @CRLF & _
"}" & @CRLF & _
".ReadMsgBody{" & @CRLF & _
" width:100%;" & @CRLF & _
"}" & @CRLF & _
"#theClass {" & @CRLF & _
" border: none;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")