re = /^(?![#.])\S*\s*\{/m
str = '#outlook a{
padding:0;
}
img[src="https://example.com"]{
-ms-interpolation-mode:bicubic;
}
table{
mso-table-lspace:0pt;
mso-table-rspace:0pt;
}
.ReadMsgBody{
width:100%;
}
#theClass {
border: none;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end