$re = '/^(?![#.])\S*\s*\{/m';
$str = '#outlook a{
padding:0;
}
img[src="https://example.com"]{
-ms-interpolation-mode:bicubic;
}
table{
mso-table-lspace:0pt;
mso-table-rspace:0pt;
}
.ReadMsgBody{
width:100%;
}
#theClass {
border: none;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);