const regex = /^(?![#.])\S*\s*\{/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![#.])\\S*\\s*\\{', 'gm')
const str = `#outlook a{
padding:0;
}
img[src="https://example.com"]{
-ms-interpolation-mode:bicubic;
}
table{
mso-table-lspace:0pt;
mso-table-rspace:0pt;
}
.ReadMsgBody{
width:100%;
}
#theClass {
border: none;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}