#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![-+.\d])[1-9]\d*(\.\d+)?cm(?![a-zA-Z])"
Local $sString = "80cm" & @CRLF & _
"80.2cm" & @CRLF & _
"80.25cm" & @CRLF & _
"71-80cm" & @CRLF & _
"-80.2cm" & @CRLF & _
"80 cm" & @CRLF & _
"80cmmm" & @CRLF & _
"08cm" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")