import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![-+.\\d])[1-9]\\d*(\\.\\d+)?cm(?![a-zA-Z])";
final String string = "80cm\n"
+ "80.2cm\n"
+ "80.25cm\n"
+ "71-80cm\n"
+ "-80.2cm\n"
+ "80 cm\n"
+ "80cmmm\n"
+ "08cm\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}