re = /(?<![-+.\d])[1-9]\d*(\.\d+)?cm(?![a-zA-Z])/m
str = '80cm
80.2cm
80.25cm
71-80cm
-80.2cm
80 cm
80cmmm
08cm
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end