using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![-+.\d])[1-9]\d*(\.\d+)?cm(?![a-zA-Z])";
string input = @"80cm
80.2cm
80.25cm
71-80cm
-80.2cm
80 cm
80cmmm
08cm
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}