using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*:.*:.*:(.*)";
string input = @"Aug 6 16:00:35 d1234567-002-e3 postfix/smtp[16032]: 3E60C7832";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}