// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*:.*:.*:(.*)").unwrap();
let string = "Aug 6 16:00:35 d1234567-002-e3 postfix/smtp[16032]: 3E60C7832";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}