$re = '/.*:.*:.*:(.*)/';
$str = 'Aug 6 16:00:35 d1234567-002-e3 postfix/smtp[16032]: 3E60C7832';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);